Symptoms
Issue: When you try to run an executable file (.exe), such as an installer, directly from your OmniStor Drive virtual drive, the system prompts that it cannot be executed or the file cannot be found.
Cause
Some .exe files (especially installers) need to run as Administrator. OmniStor Drive is mounted under your personal account, so Admin can't directly access it — which is why these .exe files won't run from the Drive.
Solution
- In OmniStor Drive, copy the .exe file to your local machine (for example, Desktop or C:\Users\YourUsername\Downloads).
- On the local file, right-click > Run as administrator.
Prevention
For any .exe files that needs to run, it is recommended to copy it to local storage to avoid hitting the same issue repeatedly.